Skip to main content

How to disable 'Waiting for Flash. Try clicking at the top of this box to activate' in chrome browser?



  • Official comment

    Just wanted to add a note here for anyone that finds this page, that the question was related to v1, and while the answer for it is true, for v2 this would not be the case.

    If you are still using v1, we recommend switching to v2. If you are using v2, then the following is the best setup.

    For application:

    <link rel="stylesheet" href="" />
    <script src=""></script>
    var ziggeoApp = new ZiggeoApi.V2.Application({
    webrtc_streaming_if_necessary: true,
    webrtc_on_mobile: true

    The way you can quickly tell if you are using v1 is to look for this:

    <ziggeo in your embedding.

    if your application setup uses


    If you are not sure or have questions about the switch, please reach out to us :)

  • Bane

    The Flash message would be shown to you if the browser that visits the page can not use WebRTC. Now looking at the code you have mentioned above, it does seem as if you did not set up WebRTC to be used at all, only Flash, so what I would suggest is to add the following:

    <script> ZiggeoApi.Config.webrtc = true;</script>

    *It would not disable that message from being shown, however it will try to use WebRTC at any time that it is possible.

    It is good to also mention that Chrome will still not allow you to use WebRTC if the page is opened over HTTP protocol, only if it is opened over HTTPS protocol would the same be possible.

    In regards to going to the recording right away, the ziggeo-disable_first_screen="true" part of your code would force it to do the same, however the person visiting your page would still be asked if they want to share the same or not.


Please sign in to leave a comment.