Post

4 followers Follow
0
Avatar

Ziggeo Player controls not working on fullscreen

Hi,

I'm working on an application that works with your api.

Turns that testin things out, found that on Chrome 64+, when I switch to fullscreen mode, controls stop working.

Why is this happening?
Is there a way to fix it?

Pablo Bertran

Please sign in to leave a comment.

13 comments

0
Avatar

Thank you for reporting this Pablo.

Can you tell me which is the exact version of Chrome that you are using?

I ask since we are resolving this as we speak and so far were only able to recreate it for 64.0.3282.140 (Official Build) (64-bit) while older versions and never versions work properly (like 64.0.3282.186 for example).

Also if you can tell us your OS or if you are using this within iframe or just a standard implementation on HTTPS page?

* just to be sure we find any other revisions where Chrome works like that.

Regards,
Bane

Bane 0 votes
0
Avatar

Hi Bane, thank's for your reply.

I'm experiencing this issue on these exporers/versions/Os so far:

  1. Chrome 64.0.3282.186 on Windows 8.1
  2. FF 58.0.2 on Windows 8.1
  3. Chrome 64.0.3282.186 on OS X 10.13.3
  4. Chrome 65.0.3325.146 on OS X 10.13.3

I'm still testing on other versions and browsers. If I find any other where I'm experiencing this, I'll let you know.

Do you have an idea of what is causing this?

Pablo Bertran 0 votes
0
Avatar

Hi Pablo,

Thank you for the list. I have tried to test this on Firefox 58 and it seems to work fine for me. I have passed the info to everyone else as well to test out, especially since we did tests and for example Chrome 64.0.3282.186 on OS X 10.13.3 works just fine as well.

Just the v 140 one is off for us so this is good to know. Can you tell me if this is happening for you on some specific page only (in which case could we be able to see if by any chance)?

For a test also, can you try playing this video: https://ziggeo.com/video-player#demo

We do have some ideas as to what might be the cause, however too early to tell at this time. The most likely reason is that some underlying application is being utilized on your end for playback instead of browser, so please do let us know if you have any specific setup (if your system player for example is set up to play the videos in your browser, or your browser is set to use it).

Bane

Bane 0 votes
0
Avatar

I have tried on the application we're developing and also on your website. (I thought your site would be the best refference to rule out any missconfiguration or third party software messing it up).

So far, I've checked over your site which explorers/versions failed and then checked on our app.

Pablo Bertran 0 votes
0
Avatar

Hi,

I'm having exactly same issue and here is a screencast where I tested  demo video on my system. As you can see controls are hidden and video is not clickable at all http://take.ms/tU8io

 

I'm using Chrome 65.0.3325.146 on OS X 10.13.3

Sergey Porotikov 0 votes
0
Avatar

Thank you both for the info.

The issue is that browser is disregarding our own setup and showing the browser native player without any controls.

* You can confirm this by right clicking on it, which should show you something like Loop option and grayed out and checked option to hide controls.

In general it seems that this is not happening for everyone, just for some specific setups and as mentioned above on our side only in Chrome.

Of course we will be applying the fix and will update you here once it (the fix) is available.

Bane 0 votes
0
Avatar

Hi to both,

Our r31 has resolved this issue. Per our tests and confirmations it seems to be working properly, of course please do feel free to test it out and let us know how it goes on your side.

The only needed change is for resources to be loaded from r31 revision like so:

(if you are using v1-stable)

<link rel="stylesheet" href="https://assets-cdn.ziggeo.com/v1-r31/ziggeo.css" />
<script src="https://assets-cdn.ziggeo.com/v1-r31/ziggeo.js"></script>

(if you are using v2-stable)

<link rel="stylesheet" href="https://assets-cdn.ziggeo.com/v2-r31/ziggeo.css" />
<script src="https://assets-cdn.ziggeo.com/v2-r31/ziggeo.js"></script>

Regards,
Bane

Bane 0 votes
0
Avatar

Hi guys.

I followed all the steps using r31 and now the problem is when I enter full screen on Chrome Version 66.0.3359.181 (Official Build) (64-bit), Ubuntu 16.04.

As you can see in attachment the video is cut.
Minimized:

Full screen:


Is there any way to fix it?

Regards,
Nikola

Nikola 0 votes
0
Avatar

Hi Nikola,

I would like to ask you for details if you do not mind, just to rule out few things and to know more about the setup:

  1. May I ask what resolution is of your monitor? (I presume 1917x1075)
  2. Also is this happening in a different browser as well by any chance?
  3. Are you using v1 or v2 of our player?
  4. can you tell us the parameters that you use in your embedding (do feel free to remove any private segments)

Regards,
Bane

Bane 0 votes
0
Avatar

Hi Bane,

Of course.
1. 1920x1080
2. No, just Chrome. On Firefox (60.0.1 (64-bit)) everything works fine.
3. v2
4. Just autoplay, width and height, if you are asking about embedding attributes?
Here is the code:

var player = new ZiggeoApi.V2.Player({
element: element,
attrs: {
autoplay: true,
height: 321,
video: token,
width: 570
}
}); player.activate();

Regards,
Nikola

Nikola 0 votes
0
Avatar

Thank you Nikola for the additional info. I have passed it to our engineer working on this aspect of our system. I will post the update here as soon as we have any news on the subject.

Bane 0 votes